KIO split (from the Job side)
David Faure
faure at kde.org
Tue Apr 18 09:21:36 BST 2006
On Tue, Apr 18, 2006 at 09:29:04AM +0200, Kevin Ottens wrote:
> > OK (without committing yet, of course, or into the bleedingedge branch)
>
> I'm not sure I understood what you meant. What's the bleedingedge branch?
You cut out the context ;) This was about "porting kdebase".
You can port it without committing, until the next snapshot update,
or if you prefer to commit that somewhere you can use (re-create, in fact)
branches/work/bleedingedge/kdebase
> And in case I wasn't clear I meant committing my changes to kdelibs trunk.
Yes, that's fine.
> > > setObjectName( "job" );
> >
> > Minor issue: I don't see the point in giving the same name to all KJobs.
> > If the name doesn't give more info than the classname already gives, it's
> > not really useful. Better let the subclasses, or the apps, name the job
> > object. Hmm, ok the above doesn't prevent that, but it just seems like an
> > unnecessary QString.
>
> Hm, ok. Just for the record this one comes from KIO::Job.
OK. Doesn't mean it's right though - especially with the new Qt4 API :)
> > > /**
> > > * Aborts this job.
> > > * This kills and deletes the job.
> > > *
> > > * @param quietly if false, Job will emit signal result
> > > * and ask uiserver to close the progress window.
> > > * @p quietly is set to true for subjobs. Whether applications
> > > * should call with true or false depends on whether they rely
> > > * on result being emitted or not.
> > > */
> > > virtual void kill( bool quietly = true ) = 0;
> >
> > Qt4/KDE4 tries to avoid booleans in APIs when they hurt readability,
> > this is such a case. This should be either an enum, or a virtual method
> > kill() and a non-virtual method killAndEmitResult which calls kill and
> > emits result. A bit of a long name though, but I don't have a better naming
> > idea right now...
>
> Sure. I noticed it, but I kept the bool but it's temporary I didn't want to
> break to many things at once. And since the signal signature changes implies
> already quite some work...
Sure. Still it should be done at some point ;)
--
David Faure
faure at kde.org
More information about the kde-core-devel
mailing list