Problems debugging kio_svn ioslave

Andreas Pakulat apaku at
Sat Nov 26 23:31:08 GMT 2005

On 25.11.05 17:28:19, David Faure wrote:
> On Thursday 24 November 2005 00:21, Andreas Pakulat wrote:
> > On 03.11.05 18:23:41, Andreas Pakulat wrote:
> > > Hi,
> > > 
> > > to solve a problem with kdevelop's subversion support I wanted to debug
> > > the kio_svn slave using KDE_SLAVE_DEBUG_WAIT=svn+http kdeinit  (svn+http
> > > is the protocoll kdevelop's subversion plugin uses) and the output in
> > > the terminal where I run this tells me that the slave is halted and
> > > detached. However after a few seconds I get a message box from kdevelop
> > > saying that the slave crashed (kdevelop's connects to the result()
> > > signal of the job) and when finally the gdb is done loading symbols I
> > > can't get any reasonable backtrace.
> > 
> > Hi,
> > 
> > I know this is considered "bad behaviour", but this is kind of a "help
> > I'm totally lost, but really want to find the error"...
> > 
> > So nobody here got a hint why the kio_svn slave crashes when it is
> > suspended via the KDE_SLAVE_DEBUG_WAIT option for kdeinit? BTW: I get
> > the same error message in konqueror telling me the slave died...
> A (slow) solution is to launch kdeinit in valgrind in a terminal (like valgrind  --tool=addrcheck --trace-children=yes kdeinit),
> and then when things seem ready over there, launch the slave and check for the valgrind output.

I can't use addrcheck ATM (at least not with the valgrind installed
here) and using memcheck the valgrind output didn't tell me anythin at

Anybody else with a suggestion?

BTW: I find it really strange that the slave crashes when it is "halted"
(i.e. using KDE_SLAVE_DEBUG_WAIT) in both konqueror and kdevelop but
in "normal" operation only crashes in konqueror... Anybody with an idea
why this happens?


Bridge ahead.  Pay troll.

More information about the kde-core-devel mailing list