[RFC] KConfigBase v KConfig

Dominik Haumann dhdev at gmx.de
Fri Nov 4 14:11:39 GMT 2005

On Friday 04 November 2005 14:47, Thomas Braxton wrote:
> On Friday 04 November 2005 07:13 am, Stephan Kulow wrote:
> > I sure hope we will change all public uses to KConfigGroup and leave
> > the kconfig objects to some setup functions - where KConfig usually
> > makes more sense.
> The only places KConfig should ever show up is where the file is opened,
> everywhere else it should be a KConfigBase.
> > If you ask to change every use of KConfig to use KConfigGroup: yes, go
> > for it!
> >
> > Greetings, Stephan
> Why would we change to KConfigGroup? I was talking about the classes that
> have a function like KConfig* SomeClass::config(), should return a
> KConfigBase*. Or a function like void SomeClass::readSettings(KConfig
> *config), should pass in a KConfigBase*. It could be a pointer to a
> KConfigGroup or a KConfig changed to the correct group, the readSettings
> function wouldn't care, as long as it gets its entries.

Maybe rename
 - KConfigBase -> KConfig
 - KConfig -> KFileConfig
as that's what it is supposed to be imo. Then KConfig could be used for all 

Only problem is the *lot of* work to do it, also very confusing if a class 
suddenly does something else. otoh: it's KDE4 and the right time to fix 
such things ;)


More information about the kde-core-devel mailing list