[PATCH] New KFileItem::assign() for Optimizing KDirListerCache
ervin at ipsquad.net
Fri Mar 25 14:23:35 GMT 2005
Le Vendredi 25 Mars 2005 14:58, David Faure a écrit :
> OK - can we name it something else than assign, though, to remove some
> possible confusion? How about load? setData? update?
> update() sounds best I guess. This is about updating the data in an
> existing kfileitem.
Not sure... as Michael pointed out the given UDSEntry can come from a
completely different URL. In this case it can be seen as creating a brand new
update/refresh could be used for something stating again the URL and loading
the resulting UDSEntry.
I tend to dislike assign, since I'd expect assigning from a KFileItem.
load or setData look like good choices...
I propose setEntry as an alternative choice though.
Kévin 'ervin' Ottens, http://ervin.ipsquad.net
"Ni le maître sans disciple, Ni le disciple sans maître,
Ne font reculer l'ignorance."
More information about the kde-core-devel