kde-common am_edit problems

Michael Buesch mbuesch at freenet.de
Fri Mar 25 11:50:14 GMT 2005

Quoting Helge Deller <deller at gmx.de>:
> BTW, I ran into the same problem as you.
> I worked around that by adding "SUBDIRS = ." to the Makefile.am, but that's not the correct solution either.

That does not work for me.

The problem is triggered by the automake conditionals
and the $(CHIPCARD_INTERFACE) variable.


libpwmanager_smartkey_la_SOURCES = smartkey.cpp \
                                 smartkey_backend.cpp \

is processed by automake to this:

@COND_PWMANAGER_CHIPCARD1_FALSE@@COND_PWMANAGER_CHIPCARD2_TRUE at am__objects_1 = chipcard2interface.lo
@COND_PWMANAGER_CHIPCARD1_TRUE at am__objects_1 = chipcard1interface.lo
am_libpwmanager_smartkey_la_OBJECTS = smartkey.lo smartkey_backend.lo \

Then am_edit fails to parse this correctly.
It exits prematurely, because of the $(am__objects_1), which is
matched by the regexps you can see in my previous patch.

My problem is, I don't understand what the perl script
is doing there. What does the $ocv variable mean? Why do we
stop processing, if we find a variable like $(am__objects_1)
in the am_libpwmanager_smartkey_la_OBJECTS variable?

Regards Michael Buesch  [ http://www.tuxsoft.de.vu ]

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20050325/e9f4db35/attachment.sig>

More information about the kde-core-devel mailing list