Fwd: detect-autoconf.pl and Debian [PATCH]

Stephan Kulow coolo at kde.org
Wed Aug 31 10:11:07 BST 2005


On Wednesday 31 August 2005 02:20, Michael Pyne wrote:
> Hi all,
>
> According to the below message, the automake shipped with Debian is 1.4 in
> the unversioned script, and so apparently detect-autoconf.pl will break
> there. detect-autoconf.pl uses the unversioned script if it exists to
> support variables like WANT_AUTOMAKE.
>
> So I constructed a patch (attached) to reject unversioned scripts if they
> aren't of a minimum version.  I would appreciate it if someone could review
> (and if you have adequate karma, apply) the patch.
>
> The alternative is to just prefer a versioned script instead.  It doesn't
> really bug me either way.
Just for the record: I don't feel like reviewing perl code, so someone else 
will have to say if it's fine

Greetings, Stephan

-- 
Mein Lebensmotto?
Man muss auch mal 1+1 gerade sein lassen k├Ânnen.




More information about the kde-core-devel mailing list