[PATCH] kdelibs: QCString length caching

Michael Pyne pynm0001 at comcast.net
Wed Oct 27 07:07:41 BST 2004


On Tuesday 26 October 2004 11:57 pm, Andre Eisenbach wrote:
> Hi!
>
> Here is a patch for the QCString .length() caching based on the
> automated test report posted on dot.kde.org.
>
> More patches coming for the other issues.
>
> Cheers,
>     Andre

Please try to maintain the coding style of the code you're editing.  For 
example, you have a variable declared 'nFileNameLength', but that section of 
code doesn't use Hungarian notation.  (Hungarian notation isn't generally a 
great idea anyways).  Anyways, I would call the variable just fileNameLength 
myself, there's no reason to encode the type in the name.

Beyond that, I've tried to check for correctness:
* kconfigbase.cpp : Looks good to me. (LGTM)
* kdesu/ssh.cpp : LGTM
* kdesu/su.cpp : 1st one LGTM, but the spacing is wrong
               : 2nd one LGTM
* kdeui/kpassdlg.cpp : LGTM
* khtml/html/html_formimpl.cpp : 1st one LGTM, but it looks like you've got a 
typo.
  : 2nd one LGTM. It alters the string, but the length doesn't change.
  : 3rd one LGTM.
* kioslave/gzip/kgzipfilter.cpp : LGTM

So in short, this set of alterations appears OK to me, but you need to correct 
some of the style issues (spacing, the typo, and the naming).

Regards,
 - Michael Pyne




More information about the kde-core-devel mailing list