RFC: A new helper class

Richard Dale Richard_Dale at tipitina.demon.co.uk
Mon Oct 4 19:14:49 BST 2004


On Monday 04 October 2004 15:13, Harri Porten wrote:
> On Mon, 4 Oct 2004, Allan Sandfeld Jensen wrote:
> > Maybe I am old-fashioned, but I prefer the traditional C-way of
> > representing this:
> > int ret;
> > ret>0 -> true
> > ret==0 -> false
> > ret<0 -> error/exception
>
> Funny. I'd interpret an value of 0 as meaning success in a C api. So it
> seems like this convention is not *that* safe ;)
I loathe it when people code something like this:

if (!strcmp(thing, otherthing)) {
    ...
}

Booleans should be booleans, and nothing else should be a boolean in my 
opinion.

-- Richard




More information about the kde-core-devel mailing list