[PATCH] KUser and new class KGroup

Oswald Buddenhagen ossi at kde.org
Thu Jun 3 19:56:13 BST 2004


On Thu, Jun 03, 2004 at 06:00:32PM +0200, Jan Schäfer wrote:
> What do you think? Can I commit?
> 
- i would put that in the same header + source as KUser. i think it's
  pointless to split them.
- as for the name, i don't think KGroup is much worse than KUser ...
  i don't care.

> +KGroup::KGroup(const KGroup & group) {
> +  d = group.d;
> +}
> +
> +void KGroup::operator =(const KGroup& group) {
> +  d = group.d;
> +}
> +
>
imho it would be best to make one of the two an inline-call to the
other.
same in KUser.

> +bool KGroup::isSuperGroup() const {
> +  return gid() == 0;
> +}
> +
this is nonsense. the root group has no special meaning.

greetings

-- 
Hi! I'm a .signature virus! Copy me into your ~/.signature, please!
--
Chaos, panic, and disorder - my work here is done.




More information about the kde-core-devel mailing list