KPasteTextAction not working

Ingo Klöcker kloecker at
Fri Jan 30 00:33:24 GMT 2004

On Thursday 29 January 2004 23:10, Andras Mantia wrote:
> Hi,
>  I was a little shocked today to see that the new KPasteTextAction is
> not working. It uses DCOP signals to get the clipboard history from
> Klipper and set the clipboard & paste the selected item from the
> history. This worked when I've implemented it, but does not work
> here. The problem is with the:
> DCOPRef klipper("klipper","klipper");
>"setClipboardContents(QString)", clipboardText);
> call. It sets the specified item in klipper, but does not put the
> text into the clipboard, thus nothing is pasted.
>  I've tried to find out where is the problem, but couldn't. If I
> print out the clipboard content in the Klipper DCOP method, it shows
> that it was set, but in the KPasteTextAction or the application which
> handles this action the same query for the clipboard return an empty
> string.	It happens also if I delay the activated() signal with
> several seconds, so it doesn't seem to be a timing problem.
>  On a second (now simple) press on the action button inserts the
> previously selected item in the document correctly, and the same
> debug output shows that now there is data in the clipboard.
> I can suspect two things:
> - qtcopy (can someone try to use this paste from history
> functionality e.g in KEdit with Qt 3.2.x ?)

Hmm, in KMail's composer I can select an item from the KPasteTextAction 
drop down list and the selected item is then pasted. I guess that's how 
it's supposed to work. I'm using qt-copy from before Qt 3.3 Beta 1 was 
imported into qt-copy and I'm not using any patches.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
URL: <>

More information about the kde-core-devel mailing list