DCOP and slots
David Faure
faure at kde.org
Tue Jan 13 07:47:40 GMT 2004
On Tuesday 13 January 2004 00:14, Ravi wrote:
> Hello,
> How do I create DCOP functions (without inheritance) which are also slots?
> Here is a short example of what I want to do:
>
> class MyClass : public QObject, virtual public DCOPObject
> {
> Q_OBJECT
> K_DCOP
> [constructors, etc. omitted]
> // k_dcop: ???
> public slots:
> void changeName(const QString &name) { doChangeName( name ); }
Tried putting k_dcop: under public slots: ? Does that work, or does moc think slots end there?
The only other way I can think of is an inline forwarder method
(but this requires using a different name for the public slot, and for the DCOP method).
--
David FAURE, faure at kde.org, sponsored by Trolltech to work on KDE,
Konqueror (http://www.konqueror.org), and KOffice (http://www.koffice.org).
More information about the kde-core-devel
mailing list