[PATCH] KTabWidget->hideTabBar( hide )

Kurt V. Hindenburg kurt.hindenburg at kdemail.net
Sat Dec 11 23:30:05 GMT 2004


On Friday 10 December 2004 03:57 pm, Stephan Binner wrote:
> setTabBarHidden() seems to fit better, and isTabBarHidden() is missing.

> In addition to what I wrote yesterday on kde-devel, @since 3.4 is missing.

On Friday 10 December 2004 05:59 pm, Richard Smith wrote:
> On Friday 10 December 2004 17:39, Kurt V. Hindenburg wrote:
> > +void KTabWidget::hideTabBar( bool hide )
> > +{
> > +    KTabWidget *that = const_cast<KTabWidget*>( this );
>
> Why is this cast needed? hideTabBar isn't a const member function...

New patch:
1. Change name to setTabBarHidden( bool )
  a. Removed the const_cast since function is not a const member.
2. Added bool isTabBarHidden()
3. Added @since3.4 to .h

Any other comments?
  Kurt
-------------- next part --------------
A non-text attachment was scrubbed...
Name: TabBarHidden.diff
Type: text/x-diff
Size: 1762 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20041211/78163cb8/attachment.diff>


More information about the kde-core-devel mailing list