fix my KCModule issues once and for all

Roger Larsson roger.larsson at norran.net
Thu Sep 25 17:09:06 BST 2003


On Wednesday 24 September 2003 19.06, Matthias Kretz wrote:
> - - -

>
> I think the second solution is nicer and should work out better in the long
> run. But if you're interested in the first patch - or even think that it's
> better let me know.

I like it :-)

>
> PS: Sorry for mixing Proxy and Decorator, it could very well be that the
> first idea is more of a Decorator while the second is a Proxy. I can still
> change the names :-)
>

If it can be used as a Widget, why not call it KCMWidget?


BTW this code - is this OK?
save() => changed!? Guess not...

kdevelop/parts/appwizard/kcmodule/module.cpp

void $APPNAME$::load()
{
    // insert your loading code here...
}


void $APPNAME$::defaults()
{
    // insert your default settings code here...
    emit changed(true);
}


void $APPNAME$::save()
{
    // insert your saving code here...
    emit changed(true);
}

An alternate way of doing this is to add a
-- 
Roger Larsson
SkellefteƄ
Sweden




More information about the kde-core-devel mailing list