[PATCH] New configDialogSize() and saveDialogSize() methods

Simon Hausmann hausmann at kde.org
Sun Jan 19 17:12:09 GMT 2003

On Sun, Jan 19, 2003 at 06:09:26PM +0100, Waldo Bastian wrote:
> On Sunday 19 January 2003 17:59, Christian Loose wrote:
> > Hi everybody,
> >
> > For Cervisia we need a possibility to save and retrieve the size of a
> > dialog to/from the configuration file of the part. So I like to add two new
> > methods to KDialogBase which receive a KConfig pointer to the corresponding
> > configuration file. This is similar to the saveLayout() and restoreLayout()
> > in KListView.
> >
> > So is the attached patch okay to commit?
> Can you let the old saveDialogSize() function call this new one so that there 
> is less code duplication? I guess that applies to configDialogSize() as well.

Also IMHO the 'if ( config )' checks are redundant. There is little
point in calling these functions with a null pointer as KConfig *
argument. How about passing a reference to a KConfig object instead?


More information about the kde-core-devel mailing list