Bug in KAction::initPrivate

Michael Brade brade at kde.org
Thu Sep 26 12:07:19 BST 2002

Thanks, Simon, for your long explanation :-)

On Thursday 26 September 2002 12:35, Simon Hausmann wrote:
> Two of the KListAction constructors had the bug that they passed the
> receiver/slot pair to the KAction constructor, which should have
> caused run-time warnings because of the signal/slot incompatibility.
> I can't remember any such warnings, but I'm pretty sure they
> happened.
Yes, and it still does if I add the connect you removed in 1.279. But the 
warning is not a signal incompatibility but a conflict.

> I'm not exactly sure how Martijn got the double connect though. Did
> the object name of the action happen to be like foo{42} ? (it's the
> only explanation I can come up with)
As it seems to me, the following causes a double connection:
  connect( this, SIGNAL(activated()), recv, SLOT(blah()) );
  connect( this, SIGNAL(activated(int)), recv, SLOT(blah()) );
However, I tried to remove the recv and the slot in KListAction to not pass 
them to the KAction constructor. Still, I got a warning about a conflict?! 
Then I tried to disconnect() that signal which didn't work either. That was 
the point when I gave up...

Here's the exact message I get every time:
QMetaObject::findSignal:KListAction: Conflict with KAction::activated(int)

Ohh.. When just adding the removed connect I get:
QMetaObject::findSignal:KSelectAction: Conflict with KAction::activated(int)
QMetaObject::findSignal:KListAction: Conflict with KAction::activated(int)

Hmm. When disconnecting or removing recv in addition to the connect I got only 
the KListAction conflict... maybe it _did_ work? But why this conflict and 
what does it mean?

## different topic:
I crashed KMail by selecting a line and pressing Ctrl-C already the second 
time (and the mail was always lost :( ). First KMail freezes, then I tried to 
quit Klipper, which takes upto half a minute, and then, some seconds later, 
KMail vanishes. Almost the same with Kate or KWrite. It happens only when 
Klipper is running. Again the Clipboard bug?

Michael Brade;                 KDE Developer, Student of Computer Science
  |-mail: echo brade !#|tr -d "c oh"|s\e\d 's/e/\@/2;s/$/.org/;s/bra/k/2'
  °--web: http://www.kde.org/people/michaelb.html

KDE 3: The Next Generation in Desktop Experience

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: signature
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20020926/14c07566/attachment.sig>

More information about the kde-core-devel mailing list