[PATCH] listdir for NetAccess

Simon Hausmann hausmann at kde.org
Tue Sep 17 08:02:05 BST 2002

On Tue, Sep 17, 2002 at 03:07:52AM +0200, Tobias Koenig wrote:
> Hi,
> can I commit the attached patch to CVS HEAD?
> I don't no if it break BC, since I've changed the constructor and
> destructor.

I can't comment on the validity of the patch because I'm a
NetAccess-Hater(tm) :) . Only two minor comments:

1) It looks binary compatible :-)

2) Can you change listdir to listDir, to be consistent with

   (the same applies to UDSEntryListToFileNames IMHO, unless it is
   supposed to be a private method -- otherwise IMHO we should use
   the same default qt/kde naming scheme which starts with a
   lower-case word -> udsEntryListToFileNames. As that would look
   odd I suggest to add a verb: convertUDSEntryListToFileNames --
   possibly it should also be moved to global.h maybe, as it's
   unrelated to NetAccess)


More information about the kde-core-devel mailing list