PATCH to make minicli use all KURIFilterPlugins

Neil Stevens neil at
Tue Oct 29 12:03:47 GMT 2002

Hash: SHA1

On Tuesday October 29, 2002 03:20, David Faure wrote:
> I don't see the need for this redundant storing. Why not implement
> plugins() (which should be called pluginNames() instead) in terms of
> "iterate over m_lstPlugins and collect names"?
> pluginNames() won't be called by all apps using the class, so the
> additional memory storage isn't worth it.
> OTOH I would still store the two lists as member variables in minicli,
> so that it doesn't have to remove() in each call to parseLine() - which
> is called for _every_ keypress!

I don't see this as really being a problem as I doubt there will exist that 
many filters, and the idea of having every user of KURIFilter doing its 
own cache bothers me, but ultimately it's not important to me which end 
the cache is on.  I just want my apidocs.

So here it is your way.

- -- 
Neil Stevens - neil at
"The nearest I can make it out, 'Love your Enemies' means, 'Hate your
Friends'." - Benjamin Franklin
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see

-------------- next part --------------
A non-text attachment was scrubbed...
Name: kdesktop-minicli-again
Type: text/x-diff
Size: 1694 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kurifilter-again
Type: text/x-diff
Size: 1278 bytes
Desc: not available
URL: <>

More information about the kde-core-devel mailing list