a patch for kdeutils/kdf/kwikdisk.cpp
Simon Hausmann
hausmann at kde.org
Mon Apr 8 15:41:48 BST 2002
On Thu, Apr 04, 2002 at 04:34:00PM +0800, Anthony Fok wrote:
> Hello,
>
> While revising kdf.po for zh_TW, I noticed that %1 was used twice in:
>
> Device [%1] on [%1] is getting critically full!
>
> but in Chinese, the order of these two parameters needs to be reversed.
> So, I suspect that it is a typo in the source code, and that the second "%1"
> should be "%2". If so, please apply the following patch. Thanks! :-)
>
>
> diff -Naur kdeutils~/kdf/kwikdisk.cpp kdeutils/kdf/kwikdisk.cpp
> --- kdeutils~/kdf/kwikdisk.cpp Thu Apr 4 16:06:17 2002
> +++ kdeutils/kdf/kwikdisk.cpp Thu Apr 4 16:06:26 2002
> @@ -207,7 +207,7 @@
> {
> if( mStd.popupIfFull() == true )
> {
> - QString msg = i18n("Device [%1] on [%1] is getting critically full!").
> + QString msg = i18n("Device [%1] on [%2] is getting critically full!").
> arg(disk->deviceName()).arg(disk->mountPoint());
> KMessageBox::sorry( this, msg, i18n("Warning"));
> }
Makes sense to me :) Comitted.
Simon
More information about the kde-core-devel
mailing list