KMediaPlayer Interface

Richard Moore rich at xmelegance.org
Sat Apr 6 02:21:11 BST 2002


A few suggestions about the details of the interface:

- Why not change the use of enum types in method parameters such as the 
setState(State) method to ints so that they can be used with the standard 
signals emitted by the various Qt widget.

- The interface should be defined as dcop interface as well as a c++ class.

- The seekable() method should be called isSeekable(), the looping() method 
should be isLooping().

- It would be nice if you could add some Q_PROPERTY declarations so the 
properties of the media object can be manipulated via its properties.

- The stateChange(...) signal should be stateChanged(...) for consistency, 
similarly, the loopingChange(..) signal.

Hope this is useful,

Rich.

On Friday 05 April 2002 9:58 pm, Neil Stevens wrote:
> Is it OK if I add this KMediaPlayer interface into kdelibs?  We've been
> having some copy and paste from app to app, and it seems to me that this is
> the way to eliminate it.
>
> Having written no KParts code in the past, I welcome any and all criticism
> of this interface.
>
> thanks,





More information about the kde-core-devel mailing list