[ANNOUNCE] CMake 2.6.4 will be required for trunk/ May 1st

Ralf Habacker ralf.habacker at freenet.de
Thu Apr 15 09:52:39 CEST 2010

Alexander Neundorf schrieb:
> Hi,
> after a short discussion on kde-buildsystem we decided that starting May 1st 
> CMake 2.6.4 will be required to build KDE trunk/, i.e. what will become KDE 
> 4.5. 
> So, you have now two weeks time to update to at least 2.6.4 in case you are 
> still using CMake 2.6.2 or 2.6.3.
> Why do we raise the required version ?
> Well, there are two things in CMake 2.6.3 which will become more and more 
> important the more projects are using CMake to install their libs, and we 
> need 2.6.3 in order to be compatible with them.
> They are 
> 1) The main thing: the find_package() command in CMake 2.6.3 additionally 
> searches in lib/cmake/Foo/ for installed FooConfig.cmake files, while CMake 
> 2.6.0..2.6.2 only look in lib/Foo/cmake/. So to be able to 
> successfully "find" those files installed to the 2.6.3-compatible location 
> currently we need some more manual work, as we do e.g. with 
> FindSharedDesktopOntologies.cmake. This works, but the more libraries we use 
> which do this, the more often we will run into this issue.
> By requiring CMake 2.6.4 it will just work and so safe us work.
> 2) Also new in CMake 2.6.3 was the feature to use parenthesis in 
> if()-statements, so you can do now
Just one question: Is it with this version be possible to use the following


in KDE related cmake scripts ?  It would be help writing if statements 
less error prone.


More information about the Kde-buildsystem mailing list