cmake cvs head - dependencies broken

Brad King brad.king at
Fri Feb 22 15:21:18 CET 2008

David Faure wrote:
> Sorry, me again :)
> With cmake cvs from today, when I modify a header file, the corresponding .cpp file (which obviously includes it)
> doesn't get recompiled !?!?
> I tried touching the CMakeLists.txt in that dir, I tried forcing a recompile of foo.cpp
> (to let it recompute dependencies if that's when it happens),
> but after that the same happens: changing the header file triggers no recompilation.

I cannot reproduce this.  Everything rebuilds correctly for me.

Did you start with a fresh build tree or run CMake from CVS on a tree
initially generated by 2.4?  Can you reproduce it in a new build tree?
What generator are you using?

If you're using the Makefiles generator, look in the build tree under
"CMakeFiles/<target-not-rebuilding>.dir".  There should be files like
"depend.make" and "CXX.includecache".  Please send them to me.


More information about the Kde-buildsystem mailing list