required CMake version is still 2.4.3

Alexander Neundorf neundorf at
Thu Mar 8 22:18:06 CET 2007

On Thursday 08 March 2007 18:53, Thiago Macieira wrote:
> Alexander Neundorf wrote:
> >Do you know when SUSE 10.3 and kUbuntu 7.04 Feisty Fawn wil be released
> > and which versions they will ship ?
> I don't care. We'll require people to install Qt even though their

I do care.
If it is possible to work on KDE with the software as it comes with your 
distro the entry barrier to development is much lower.

> distributions have 4.2.2 already.
> We're requiring that people compile many hours' worth of software to get
> to a working state. Why not CMake?

If it is required, sure.
If it's not required, I don't want to waste peoples time by requiring them to 
update cmake.
Until now it wasn't required.

Dirk Mueller complained strongly when requiring cmake 2.4.3 because it was so 
much effort to get the Coverity build updated.

Bill Hoffman from Kitware stopped the Nightly Builds of kdelibs he did on one 
of his own machines because keeping up with the changing requirements of KDE 
was too much work.

Same for me. If I come home after work and have 2 or 3 hours to do something 
on KDE, do svn up and notice that I can't work on what I wanted to do because 
of new requirements I usually won't be able to work on this for that day. 

If we want to get KDE4 out before Qt5 is released ;-) we should try to make 
developing for it not harder than it has to be.

And, maybe most important, if we require a newer version of CMake, this needs 
to be brought up on k-c-d or k-b-s ;-) and then announced with at least one 
week warning period.
And the required version in FindKDE4Internal.cmake HAS to be adjusted 

Work: alexander.neundorf AT -
Home: neundorf AT                -
      alex AT               -

More information about the Kde-buildsystem mailing list