[SOLVED] Re: cmake 2.4.* does not create moc files in kdepimlibs

Friedrich W. H. Kossebau Friedrich.W.H at kossebau.de
Sat Aug 12 23:11:44 CEST 2006

Am Freitag, 11. August 2006 13:05, schrieb Friedrich W. H. Kossebau:
> Hi,
> cmake 2.4.* seems to fail creating moc files in kdepimlibs (current svn).
> [  0%] Building CXX object
> kxmlrpcclient/CMakeFiles/kxmlrpcclient.dir/server.o
> /home/koder/Programmieren/kdesvn/trunk/KDE/kdepimlibs/kxmlrpcclient/server.
>cpp:185:22: error: server.moc: Datei oder Verzeichnis nicht gefunden
> make[2]: *** [kxmlrpcclient/CMakeFiles/kxmlrpcclient.dir/server.o] Fehler 1
> make[1]: *** [kxmlrpcclient/CMakeFiles/kxmlrpcclient.dir/all] Fehler 2
> make: *** [all] Fehler 2
> Same for other subdirs, all moc dependencies are missing.
> In other modules like kdebase, kdeutils and kdelibs everything works fine.
> I tried cmake 2.4.{1,2,3}...
> Any idea how to debug this?

By digging for the last revision that builds, for example, and checking every 
single change to the first that doesn't. With some luck it was already the 
second change, which triggered the failed build:

The passing of 1 as a variable to the macro "macro_bool_to_01" was the 
culprit. CMakeLists.txt in kdepimlibs contained
	macro_bool_to_01(LDAP_FOUND HAVE_LDAP 1)
	macro_bool_to_01(SASL2_FOUND HAVE_SASL2 1)

Removing the 1 made sense and gave me a working build again, hurra :)
Just don't ask how many hours were spend :/

Bill, perhaps cmake should detect such wrong variables in further versions? ;)

Thanks for trying to help, Alex and Bill, :)

More information about the Kde-buildsystem mailing list