cmake 2.4.* does not create moc files in kdepimlibs

Friedrich W. H. Kossebau Friedrich.W.H at
Fri Aug 11 17:39:42 CEST 2006

Am Freitag, 11. August 2006 17:26, schrieb William A. Hoffman:
> At 11:00 AM 8/11/2006, Friedrich W. H. Kossebau wrote:
> >Hi Bill,
> >
> >Am Freitag, 11. August 2006 15:05, schrieb William A. Hoffman:
> >> The dashboard for kdelibs looks good:
> >
> >Yes, kdebase, kdeutils and kdelibs do fine for me. But kdepimlibs does
> > not. Brad Hards on irc reported the same problems for kdegraphics.
> >
> >>
> >>shb oard.html
> >>
> >> Mingw is the only platform not building.  The error you are getting
> >> usual comes from generated moc sources not being added to the target
> >> they are used in (even if they are header files).
> >
> >With the help of Tobias König I managed to reduce the problem to the
> > following line in "MACRO (KDE4_AUTOMOC)" in KDE4Macros.cmake:
> >      if (EXISTS ${_abs_FILE} AND NOT _skip)
> >
> >Usually EXISTS ${_abs_FILE} returns true and _skip is "NOTFOUND", like
> >debugging with message() tells.
> >
> >For whatever(!) reason in kdepimlibs the full expression returns false, in
> >kde{libs,base,utils} returns true for the same values!
> >
> >We are lost. What is happening here?
> Add some message("looking for: [${_abs_FILE}] ") calls into the macro and
> re-run cmake.  Maybe it will shed some light on the issue.

Thanks, but this is what we already did (I tried to tell this above 
with "debugging with message()").

I tried now with splitting the AND condition into two ifs:
      if (EXISTS ${_abs_FILE})
      if (NOT _skip)
and corresponding endifs. 

No luck. Now cmakes stops with:

CMake Error: Error in cmake code at
\nMissing Requirements:${_requirements}:180:
file "/home/koder/Programmieren/kdesvn/trunk/KDE/kdepimlibs/kxmlrpcclient/server.cpp" 
the moc file "server.moc" is included, 
but "/home/koder/Programmieren/kdesvn/trunk/KDE/kdepimlibs/kxmlrpcclient/server.h" 
doesn't exist.
Current CMake 
stack: /home/koder/Programmieren/kdesvn/trunk/KDE/kdepimlibs/kxmlrpcclient/CMakeLists.txt

"\nMissing Requirements:${_requirements}" is sometimes a different, random 
And /home/koder/Programmieren/kdesvn/trunk/KDE/kdepimlibs/kxmlrpcclient/server.h 
does(!) exist.

But: no crash for kdelibs, kdebase, kdeutils.


More information about the Kde-buildsystem mailing list