[Kde-bindings] KDE/kdepimlibs/kholidays

John Layt john at layt.net
Fri May 14 21:31:52 UTC 2010


SVN commit 1126791 by jlayt:

KHolidays API clean-up

Some changes to make the new KHolidays API more sensible/usable.

API changes are in HolidayRegion class only.  This looks bigger than it is as
the Bison/Flex parser was regenerated due to the API changes, this part can be
completely ignored.

1) Rename regionCode() to countryCode() to avoid any confusion with the actual
   HolidayRegion code.
2) Old behaviour of location() has been restored but is now deprecated and
   replaced by regionCode().  It's bad practice to change behaviour of existing
   functions, Bad John!  The constructor tries to accept either for backwards
   compatability.
3) Rename shortName() to name()
4) Rename longName() to description() and change functionality slightly.
4) Provide static versions of the metadata api, otherwise client apps would
   have to create an instance themselves just to display the name for the
   user to choose.

Fixes a coupe of minor bugs, adds some missing strings.

All tests pass, existing clients work properly again..

CCMAIL: kde-bindings at kde.org



 M  +10 -0     DESIGN  
 M  +159 -19   holidayregion.cpp  
 M  +104 -17   holidayregion.h  
 M  +1 -1      holidays/CMakeLists.txt  
 D             holidays/plan1/holiday_jp-ja  
 A             holidays/plan1/holiday_jp_ja   holidays/plan1/holiday_jp-ja#1124566
 M  +9 -4      parsers/holidayparserdriver.cpp  
 M  +15 -7     parsers/holidayparserdriver_p.h  
 M  +7 -6      parsers/plan1/holidayparserdriverplanold.cpp  
 M  +20 -10    parsers/plan2/holidayparserdriverplan.cpp  
 M  +3 -2      parsers/plan2/holidayparserdriverplan_p.h  
 M  +328 -315  parsers/plan2/holidayparserplan.cpp  
 M  +8 -7      parsers/plan2/holidayparserplan.hpp  
 M  +10 -6     parsers/plan2/holidayparserplan.ypp  
 M  +1033 -1024 parsers/plan2/holidayscannerplan.cpp  
 M  +4 -2      parsers/plan2/holidayscannerplan.lpp  
 M  +9 -7      tests/holiday_gb-eaw_en-gb_Test  
 M  +28 -16    tests/testholidayregion.cpp  
 M  +5 -4      tests/testholidayregion.h  
 M  +6 -4      tests/testparseholiday.cpp  


http://websvn.kde.org/?view=rev&revision=1126791



More information about the Kde-bindings mailing list