[Kde-bindings] SIGSEGV when running Qyoto apps?

IBBoard ibboard at gmail.com
Sun Feb 21 14:28:04 UTC 2010

I've been using Qyoto for a while now and am getting used to the
signals/slots way of doing things. Generally everything is okay, and the
link of MonoDevelop to Qt Creator is usable, but I do seem to be having
some stability issues (which was one of my first concerns after comments
from Erik/FireRabbit). Before I filed a bug I wanted to check whether
there were any obvious causes I might be missing.

Basically, after an indeterminate amount of time (sometimes in the
middle of executing a menu action, sometimes while resizing panels,
sometimes while just moving the mouse over the window) my app crashes
and prints out:

The application was terminated by a signal: SIGSEGV

SIGSEGV is apparently a segfault from accessing incorrect memory areas.
Given that my app is .Net and hence "managed" code then I wouldn't have
thought it could cause it directly. I've tried a static reference to the
main window in case that helped [1], with no luck. I've also tried using
all the standard RPMs from openSUSE (mono-qt 4.3.1 with libqt4 4.5.3) as
well as with newer versions of Qt (4.6.0).

Are there any known problems that could cause this? Or any good ways to
get some more information to determine if it is just versioning issues?



[1] http://lists.kde.org/?l=kde-bindings&m=126631049207173&w=2

More information about the Kde-bindings mailing list