[Kde-bindings] qtruby doesn't work

Andreas Pakulat apaku at gmx.de
Fri Oct 12 13:00:43 UTC 2007


today I tried to install the KDE4 ruby bindings, first problem was the
kde-smoke bindings wouldn't build, possibly due to changes to kdeprint.
I removed all kdeprint stuff from the kde_headers file and all built and

But runnint qt4 ruby apps didn't work, first problem is that it only
installed qtruby4.so as module which means no .so.x.x.x only the .so.
This doesn't work because "require qtruby4" expects a shared library, at
least it works as soon as I change from MODULE to SHARED and then let it
install again.

But after doing so I get a segfault when running a simple qt ruby app
(examples/dialogs/standarddialogs/main.rb), the backtrace is useless it
only shows libruby1.8.so.1.8 and nothing else.

So what should I do now? I tried setting cmake's build type to debugfull
but that doesn't help to get a better backtrace.

Could this be related to installing the ruby-stuff into
$HOME/kde4/lib/ruby/1.8 (and ../i486-linux) and changing RUBYLIB to
include these two directories? I'd like to not have to install the
bindings into /usr/local to use them and also don't want to have a
full-blown ruby build in my home either.


Don't plan any hasty moves.  You'll be evicted soon anyway.

More information about the Kde-bindings mailing list