[Kde-bindings] Questions About the New Schedule

Sebastian Sauer mail at dipe.org
Tue Oct 2 18:06:59 UTC 2007

Richard Dale wrote:

> http://ktown.kde.org/~dirk/dashboard/

ah, great to see the err now. probably I need to bookmark that link too :)
> Global symbol "$qt_defines" requires explicit package name at (eval 1)
> line 4. Global symbol "$qt_defines" requires explicit package name at
> (eval 1) line 4. Global symbol "$qt_defines" requires explicit package
> name at (eval 1) line 4.
>         ...propagated at kdebindings-717467/kalyptus/kalyptus line 227.
> make: *** [smoke/plasma/smokedata.cpp] Error 255
> make: *** [smoke/plasma/CMakeFiles/smokeplasma.dir/all] Error 2
> make: *** [all Error 2

Seems I can't reproduce that err on any of my boxes too. But I run into a few 
other problems on a Kubuntu 7.10 system (well, I am not 100 percent sure if 
it isn't the box that just doesn't work anymore correct since it seems the 
latest (K)ubuntu dist-upgrade did broke a few systems);

[ 46%] Generating korundum4_automoc.cpp
Scanning dependencies of target korundum4
[ 47%] Building CXX object 
[ 48%] Building CXX object 
[ 48%] Building CXX object 
Linking CXX shared library ../../../lib/korundum4.so
/usr/bin/ld: cannot find -lsmokekde

The reason seems to be, that in smoke/CMakeLists.txt the option 
ENABLE_SMOKEKDE is off by default and plasma got compiled even if it's off 
while I assume that plasma depends on korundum... Compiling 
with -DENABLE_SMOKEKDE=ON fixes that err.

[ 68%] Generating chatsetnickname.cs
/bin/sh: ../../../tools/uics/uics: not found
make[2]: *** [csharp/qyoto/examples/qdbus/chat/chatsetnickname.cs] Error 127
make[1]: *** [csharp/qyoto/examples/qdbus/chat/CMakeFiles/chat.dir/all] Error 

it seems in csharp/qyoto/CMakeLists.txt the
does point to the wrong directory. I did the compile direct in the 
kdebindings-directory and not in e.g. kdebindings/csharp/

Linking CXX shared library ../../../lib/korundum4.so
/usr/bin/ld: /home/kde4/svn/_build/kdebindings/lib/libqtrubyinternal.a(Qt.o): 
relocation R_X86_64_32 against `a local symbol' can not be used when making a 
shared object; recompile with -fPIC
/home/kde4/svn/_build/kdebindings/lib/libqtrubyinternal.a: could not read 
symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [lib/korundum4.so.0.0.0] Error 1
make[1]: *** [ruby/korundum/src/CMakeFiles/korundum4.dir/all] Error 2

I remember to have seen such an err-message before a few years back but atm I 
really don't remember the context. Probably it was cause I tried to link 
against something that isn't a shared lib or so...

More information about the Kde-bindings mailing list