[Kde-bindings] [Bug 110415] New: [qtruby] allow Qt::Object::inherits to use QtRuby syntax
Caleb Tennis
caleb at gentoo.org
Mon Aug 8 19:06:35 UTC 2005
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
http://bugs.kde.org/show_bug.cgi?id=110415
Summary: [qtruby] allow Qt::Object::inherits to use QtRuby syntax
Product: bindings
Version: unspecified
Platform: Compiled Sources
OS/Version: Linux
Status: NEW
Severity: wishlist
Priority: NOR
Component: general
AssignedTo: kde-bindings kde org
ReportedBy: caleb gentoo org
Version: (using KDE KDE 3.4.2)
Installed from: Compiled From Sources
One nice feature would be to allow Qt::Object::inherits() to use the QtRuby naming scheme for valid lookups. For example, right now:
irb(main):001:0> w = Qt::Widget.new(nil)
irb(main):002:0> w.inherits("Qt::Widget")
=> true
irb(main):003:0> w.inherits("Qt::Object")
=> false
irb(main):004:0> w.inherits("QWidget")
=> true
irb(main):005:0> w.inherits("QObject")
=> true
inherits works for "QObject", but my wish is that it worked for "Qt::Object" as well.
More information about the Kde-bindings
mailing list