[Kde-announce-apps] Peagle 0.2.0

Martin Eitzenberger martin at psiplus.at
Tue Apr 25 00:21:22 CEST 2006

Name: Peagle
Version: 0.2.0
Type: Web Application
License: GPL
Homepage: http://www.psiplus.at
More Info:

 Peagle is a Stand-Alone Web-Frontend for the
Beagle-Search-Engine with the look and feel from
known web search engines.

It requires PHP 4.3 (with gd, sockets and
posix-modules) or higher and Beagle 0.2 or higher
to run.

Currently it supports linking the results directly
or running them using KDE-Helpers (kfmclient) or
GNOME-Helpers... It would be easy to implement the
same feature for other desktop-environments.

To install, do the following:
- Install and configure php with gd, socket and
posix extensions. In (K)Ubuntu you can install
these packages: php5, php5-gd.
- Unpack the peagle-package, and run the
(or ./peagle.php)

(Start the beagle-daemon, if it is not already
running: beagled --bg --replace ... You usually
don't have to do this if you already use other
beagle-utils like kerry)

Ready! You can access peagle then via:

Have Fun!

 Peagle 0.2.0 Changes:
- Integrated Webserver (not dependant on external
webservers anymore!)
- Better autodetection - nearly no configuration
- Now supporting GNOME too, next to KDE and direct
linking (thanks to Juhaz)

More information about the Kde-announce-apps mailing list