Review Request: Add functions to get the size of a component

Arjen Hiemstra djfreestyler at gmail.com
Wed Aug 15 18:45:05 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/106047/#review17471
-----------------------------------------------------------



engine/component.h
<http://git.reviewboard.kde.org/r/106047/#comment13672>

    I think it would be better if this returned an actual axis-aligned bounding box object rather than an arbitrary vector. This AABB would act a little like QRect and also make it easier to create a combined AABB for the GameObject.



engine/component.h
<http://git.reviewboard.kde.org/r/106047/#comment13673>

    I think "transformCenter" is a better name for this property as that what it is mainly used for. Also, since there is no null vector it might be better to call it a zero-length vector everywhere.


- Arjen Hiemstra


On Aug. 15, 2012, 5:59 p.m., Felix Rohrbach wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/106047/
> -----------------------------------------------------------
> 
> (Updated Aug. 15, 2012, 5:59 p.m.)
> 
> 
> Review request for Gluon.
> 
> 
> Description
> -------
> 
> I'd like to have these functions to compute the size of GameObjects.
> 
> 
> Diffs
> -----
> 
>   engine/component.h db86220 
>   engine/component.cpp 2999d84 
> 
> Diff: http://git.reviewboard.kde.org/r/106047/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Felix Rohrbach
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/gluon/attachments/20120815/dd1a141b/attachment-0001.html>


More information about the Gluon mailing list