Review Request: Tests for gluonobject

Laszlo Papp lpapp at kde.org
Sun Sep 4 18:13:30 UTC 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/102483/#review6264
-----------------------------------------------------------



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5505>

    I would prefer childObjectName. If there was childFoobar, you would not know what the childName refers to. In this case, it could work, but I think it is nice to make it consistenly.



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5506>

    childObjectName argument accordingly.



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5507>

    Why not the following:
    
    QString gluonObject1Name = "GluonObject1";
    QString gluonObject2Name = "GluonObject2";
    QString gluonObject3Name = "GluonObject3";
    
    and then below:
    gluonObject1Name + "/" + gluonObject2Name;
    
    gluonObject1Name + "/" + gluonObject2Name + "/" + gluonObject3Name;
    



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5508>

    why not:
    GluonObject parentObect(parentObjectName);
    GluonObject childObject(childObjectName); 
    
    and then below ?
    
    parentObjectName ? + "/" + childObjectName ?



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5510>

    Could you please use Java style iterator in test codes like this ? The reason is that, Java style iterator is easier to read and maintain because it is cleaner and smaller. Test codes should be as clear and simple as possible.
    
    We have 12 keys here, so the performance drawback for this method is negligible.



core/tests/gluonobjecttest.cpp
<http://git.reviewboard.kde.org/r/102483/#comment5509>

    Previously, you had the i.key() as an argument of the newRow() method.
    
    Please use spaces after the "<<" operation to make it more readable.


- Laszlo


On Sept. 3, 2011, 6:45 a.m., Ashwin Rajeev wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/102483/
> -----------------------------------------------------------
> 
> (Updated Sept. 3, 2011, 6:45 a.m.)
> 
> 
> Review request for Gluon.
> 
> 
> Summary
> -------
> 
> Add few new test cases in gluonobjecttest
> {testAddChildAt,testQualifiedname,testFullyqualifiedname,testNameToObjectName,testSetProperty}
> 
> 
> Diffs
> -----
> 
>   core/tests/gluonobjecttest.h a9e0d06 
>   core/tests/gluonobjecttest.cpp 5b380a6 
> 
> Diff: http://git.reviewboard.kde.org/r/102483/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Ashwin
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/gluon/attachments/20110904/0da23cf2/attachment-0001.html>


More information about the Gluon mailing list