Review Request: Achievements 20: Add a threshold value to the Achievement class

Arjen Hiemstra djfreestyler at gmail.com
Sat Nov 26 17:46:07 UTC 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/103253/#review8488
-----------------------------------------------------------



engine/achievement.h
<http://git.reviewboard.kde.org/r/103253/#comment7201>

    Minor correction: use hasMadeProgress instead of just madeProgress, fits better with other bool method names. Though personally I'd call it isPastThreshold instead, since that avoids adding another term into the API.



engine/achievement.cpp
<http://git.reviewboard.kde.org/r/103253/#comment7202>

    No real need for braces here, but not much of an issue.



engine/achievementsmanager.h
<http://git.reviewboard.kde.org/r/103253/#comment7203>

    See previous comment about using hasMadeProgress.



engine/achievementsmanager.cpp
<http://git.reviewboard.kde.org/r/103253/#comment7204>

    Would it be an idea to keep the logic to show hidden achievements and instead have the UI decide how to show them? If you completely hide them from the list the UI will never be able to touch them.


- Arjen Hiemstra


On Nov. 26, 2011, 3:47 p.m., Felix Rohrbach wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/103253/
> -----------------------------------------------------------
> 
> (Updated Nov. 26, 2011, 3:47 p.m.)
> 
> 
> Review request for Gluon.
> 
> 
> Description
> -------
> 
> With this threshold value you define when the player starts to make progress. Hidden achievements will be shown as soon as the player starts to make progress.
> 
> Further changes:
> - AchievementsManager::dependency now returns the index of the dependency
> - Don't even show hidden elements to the delegate, so that rowCount == achievementsCount.
> 
> This is the last commit in my achievements branch :). After that, only the new delegate (which I have to rewrite) is missing.
> 
> 
> Diffs
> -----
> 
>   engine/achievement.h 5d8403a 
>   engine/achievement.cpp 4a5e544 
>   engine/achievementsmanager.h 785226a 
>   engine/achievementsmanager.cpp ae95ddd 
> 
> Diff: http://git.reviewboard.kde.org/r/103253/diff/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Felix Rohrbach
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/gluon/attachments/20111126/d6aff8ba/attachment.html>


More information about the Gluon mailing list