funq: syntax that doesn't scare off C++ developers

Samuel Gaist samuel.gaist at edeltech.ch
Sat Jul 26 09:14:29 UTC 2014


On 26 juil. 2014, at 07:51, Aaron J. Seigo <aseigo at kde.org> wrote:

> On Saturday, July 26, 2014 00:48:59 Samuel Gaist wrote:
>> When you say namespaced, do you mean something like:
>> 
>> qore.std.debug::log(z)
> 
> Exactly. The goals are:
> 
> * not too much to type (though autocomplete in editors helps a lot)
> * won't conflict with your application code by accident
> 
> Funny story: one of the languages I spent a fair amount of time with while 
> researching for this project was Erlang. Its standard library of modules are 
> not namespaced. One of them is called "user". Guess what happens if you have a 
> module called "user"? ;)
> 

Sounds good

Just to be sure, let say the core namespace is funq, would it look like

public funq 1.0
{
   public std 1.0
   {
       public debug 1.0
       {
               func log(value) { pretty_print(value); }
       }
   }
}

On a side note, is there already a file naming convention ?

Also, how to regroup several fqt files as a library ?


More information about the Funq-devel mailing list