[FreeNX-kNX] FreeNX issue

riverbridge at hushmail.com riverbridge at hushmail.com
Mon Mar 5 16:16:59 UTC 2012

Hello. Any help would be greatly appreciated. I am having an issue 
with freenx-server after rebooting. I have tried CentOS 6.2 and 
Fedora 16.

On Fedora, to install I did:
sudo yum install freenx-server nx
sudo nxsetup --install --setup-nomachine-key
systemctl enable sshd.service
systemctl enable freenx-server.service
service sshd start
service freenx-server start
I have tried with iptables turned off and on.

It will work after the install, but as soon as I reboot, I start 
getting this error with any account when using the Nomachine 
Windows client:

NX> 203 NXSSH running with pid: 3832
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: x.x.x.x on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.5.0)
NX> 105 hello NXCLIENT - Version 3.2.0
NX> 134 Accepted protocol: 3.2.0
NX> 105 login
NX> 101 User: foobar
NX> 102 Password: 
NX> 103 Welcome to: foomachine1 user: foobar
NX> 105 listsession --user="foobar" --status="suspended,running" --
geometry="1920x1080x32+render" --
NX> 127 Sessions list of user 'foobar' for reconnect:

Display Type             Session ID                       Options  
Depth Screen         Status      
Session Name
------- ---------------- -------------------------------- -------- -
---- -------------- ----------- 

NX> 148 Server capacity: not reached for user: foobar
NX> 105 startsession  --link="adsl" --backingstore="1" --
encryption="1" --cache="16M" --images="64M" 
--shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --
session="new%20foomachine1" --
type="unix-gnome" --geometry="1914x985" --client="winnt" --
keyboard="pc102/en_US" --

NX> 1000 NXNODE - Version 3.2.0-74-SVN OS (GPL, using backend: 
NX> 700 Session id: foomachine1-2002-
NX> 705 Session display: 2002
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: 20431dec78b27248e42f1309119d5cc1
NX> 702 Proxy IP: y.y.y.y
NX> 706 Agent cookie: 20431dec78b27248e42f1309119d5cc1
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 /usr/libexec/nx/nxserver: line 1585:  3735 Terminated       
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot 
node.conf and investigate "/home/foobar/.nx/F-C-foomachine1-2002-
1ADC29310BD86C2F2B11F721894A9C4E/session". You might also want to 
try: ssh -X myserver; 
/usr/libexec/nx/nxnode --agent to test the basic functionality. 
Session log follows:
NX> 1006 Session status: closed
NX> 1001 Bye.
Can't open 
C4E}: No such file or 
mv: cannot stat 
9C4E}': No such 
file or directory
/usr/libexec/nx/nxserver: line 578: kill: (3411) - No such process
NX> 280 Exiting on signal: 15

I have tried removing all files in /tmp, removing the .nx and 
.cache directories in the home directory of a user, removing the 
.Xauthority file in a user's home directory as well as in 
/var/lib/nxserver/home, I have tried removing the session files in 
/var/lib/nxserver/db/* directories, I have tried running nxserver --
cleanup. I tried adding another test user and that user gets the 
same response. I tried changing the DISPLAY_BASE variable to a 
different value. I checked the permissions of files in 
/var/lib/nxserver against a Fedora 14 server that this seems to be 
working fine on, and they were the same.

If i change SESSION_LOG_CLEAN to 0, and check the session file in 
the user's directory, I see this:

Error: Aborting session with 'Cannot establish any listening 
sockets - Make sure an X server isn't already running'.
Session: Aborting session at 'Mon Mar  5 11:09:26 2012'.
Session: Session aborted at 'Mon Mar  5 11:09:26 2012'.
xrdb: Connection refused
xrdb: Can't open display ':12010'

** (gnome-session:9893): WARNING **: Cannot open display:

An X server is running on the server, but it is running on our old 
server as well and it seems to run fine.

Does anyone have any ideas? I have tried everything I can think of 
or have seen as suggestions. Thanks.

More information about the FreeNX-kNX mailing list