[FreeNX-kNX] Re: Problem running KDE applications in rootless sessions on Ubuntu 10.04 LTS (Lucid Lynx)

chris at ccburton.com chris at ccburton.com
Wed Mar 2 17:09:02 UTC 2011

Stefan Baur <newsgroups.mail2 at stefanbaur.de> wrote on 02/03/2011 13:11:12:

> Hi list,

> I'm having issues with sessions terminating unexpectedly when tring 
> to run certain KDE applications.
> Server:
> Ubuntu 10.04 LTS (Lucid Lynx) with FreeNX installed via
> deb http://ppa.launchpad.net/freenx-team/ppa/ubuntu lucid main 
> deb-src http://ppa.launchpad.net/freenx-team/ppa/ubuntu lucid main 
> Client: 
> Windows 7 Home Premium with Nomachine NXClient 3.4.0-5
> To debug the issue, I did the following:
> Start xterm in rootless mode
> Run "screen" in xterm
> Run a regular SSH session (using PuTTY)
> Connect the PuTTY session to the xterm-screen by issuing "screen -x"
> Run "konqueror ~" in xterm
> NX session aborts; the screen session in PuTTY shows the following 
> surfer1 at surfbox:~$ konqueror ~


> kded4: Fatal IO error: client killed
> (here's where it crashes)

I just tried the senario you describe on suse 11.2 and it works fine,
with a Konqueror session on the remote machine.

I can detach from screen in xterm and kill the xterm, and I
still have a functioning konqueror and can attach/detach to screen
from the separate ssh session.

I don't see any qt_plugin stuff tho' so you culd try some different
kde apps or non kde like firefox, but you probably need to look at
those errors and the deprecated signal stuff too.

Which kde4 are you running ??

> If I run a full-screen KDE session, it doesn't crash:
> surfer1 at surfbox:~$ konqueror ~


> What's going on here? Any ideas? Is this a bug? Is there a 
> workaround for rootless sessions and KDE applications?
> Kind Regards,
> Stefan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/freenx-knx/attachments/20110302/2a31ca90/attachment.html>

More information about the FreeNX-kNX mailing list