[FreeNX-kNX] CentOS5 Freenx installation won't start and /var/log/nxserver.log is empty

Terje Andersen terander at guard.zapto.org
Sat Feb 7 00:19:53 UTC 2009

On Fri, 6 Feb 2009 12:35:58 -0700
Joseph Thames <beartham at gmail.com> wrote:

> Hello,

Hi there :-)

> I am configuring two 64-bit VPS platforms for KDE-based SaaS products, one
> Ubuntu 8.04 and one CentOS 5. After about two weeks work, with assistance of
> Marcelo Shima, and my VPS vendor, I finally got Freenx working on the Ununtu
> platform. The problem was pseudo-terminals, and we had to disable udev, as
> Ubuntu's *expect *apparently requires static ptys in /dev.

Hmm, never seen this issue on *buntu before.

> On the client-side I am using the NXclient downloaded from the NoMachine
> website. I have now tested and configured the KDE 3.5 desktop on the Ubuntu
> server from my 32-bit Fedora 8 client box.
> So far I have been unable to login to the CentOS 5 Freenx, from the Fedora
> client. The client-side message was:
> The NX service is not available or the NX access was disabled on host
> And the details were:
> NX> 203 NXSSH running with pid: 10548
> NX> 285 Enabling check on switch command
> NX> 285 Enabling skip of SSH config files
> NX> 285 Setting the preferred NX options
> NX> 200 Connected to address: on port: 22
> NX> 202 Authenticating user: nx
> NX> 208 Using auth method: publickey
> NX> 204 Authentication failed.
> Here are some of the things I have tried:
>    1. NX_LOG_LEVEL=6 (debugging), but I get an empty /var/log/nxserver.log,
>    even though it's owner is nx and group is  root, and I chmod'd it to 660.
>    2. SESSION_LOG_CLEAN=0 to enable the temporary log
>    ($HOME/.nx/C-<hostname>-<display>-<session_id>), but the .nx subdirectory
>    does not appear after I tried the client login,
>    3. From an ssh session of user 'bear' on the server, I executed:
>     echo "<password>" | /usr/bin/nxnode-login -- ssh "bear" "22" >>
>    "/usr/bin/nxnode" --check
>    response:
>    -bash: /usr/bin/nxnode: Permission denied
>    4. Also from user 'bear' on the server:
>    [bear at xeon ~]$ nxagent :1000
>    response:
>    NXAGENT - Version 3.2.0
>    Copyright (C) 2001, 2007 NoMachine.
>    See http://www.nomachine.com/ for more information.
>    Info: Agent running with pid '31880'.
>    Session: Starting session at 'Fri Feb  6 10:11:00 2009'.
>    Error: Aborting session with 'Unable to open display '''.
>    Session: Aborting session at 'Fri Feb  6 10:11:00 2009'.
>    Session: Session aborted at 'Fri Feb  6 10:11:00 2009'.
> I installed Freenx on the CentOS VPS as recommend from the CentOS wiki Howto
> on FreeNX. <http://wiki.centos.org/HowTos/FreeNX?highlight=%28Freenx%29>
> Now I am about to try its next recommendation (2. Key-based authentication),
> disabling ssh Password Authentication and setting
> ENABLE_PASSDB_AUTHENTICATION="1" in node.conf to utilize the PASSDB
> authentication approach.; then requiring --adduser and --passwd for each
> user.
> I didn't have to do this on Unbuntu. So I would rather not, if there is
> another way.
> Any other recommendations, anyone?

1) Try (as root):
/usr/bin/nxsetup --test

examine the output from that one

2) Try (as root):
/usr/bin/nxsetup --clean --purge --install --setup-nomachine-key

3) Check that the user 'nx' can log into the box over SSH - look in the SSHD config. Look at the FAQ (see bottom of mail) for info on how to test a connection as the user 'nx'.

4) do _not_ do the part where you change SSHD config (PasswordAuthentication no), atleast not until you have everything working with SSH authentication - then you can consider to change the authentication into passdb, if you like/need it.


More information about the FreeNX-kNX mailing list