D26932: Prompt user when KWallet is disabled
David Rosca
noreply at phabricator.kde.org
Wed Jan 29 14:34:46 GMT 2020
drosca requested changes to this revision.
drosca added inline comments.
This revision now requires changes to proceed.
INLINE COMMENTS
> kwalletpasswordbackend.cpp:176
>
> +void KWalletPasswordBackend::showPrompt()
> +{
Probably should be called different name, as now it is no longer showing any "prompt".
> kwalletpasswordbackend.cpp:179
> + if (!initialized) {
> + initialized = true;
> + mApp->desktopNotifications()->showNotification("KWallet disabled","Please enable KWallet to save password.");
Don't use global static here, instead move the static inside the function.
> kwalletpasswordbackend.cpp:180
> + initialized = true;
> + mApp->desktopNotifications()->showNotification("KWallet disabled","Please enable KWallet to save password.");
> + }
Needs to be translated (`tr()`) and coding style - space after comma.
> kwalletpasswordbackend.cpp:183
> +
> + return;
> +}
It's a `void` function so there is no reason to add empty return statement at the end.
REPOSITORY
R875 Falkon
REVISION DETAIL
https://phabricator.kde.org/D26932
To: puneethchanda, SGOrava, drosca
Cc: drosca, alukichev, falkon, grune, akilgus, siraj_qazi, saishm, anmolgautam, SGOrava, iodelay, spoorun, ptabis, navarromorales, clivej, mparillo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/falkon/attachments/20200129/b3646f83/attachment.html>
More information about the Falkon
mailing list