<p>If you use digikam from my PPA then, for the moment, you need to uninstall the digikam extra library packages with my PPA and digikam and then reinstall digikam so you use the official digikam 2.1.1 as my packages doesn't support Ubuntu 11.10 yet. I will start working on support for 11.10 this weekend.</p>

<p>/Philip<br>
</p>
<div class="gmail_quote">On Oct 14, 2011 9:37 AM, "Remco ViŽtor" <<a href="mailto:remco.vietor@wanadoo.fr">remco.vietor@wanadoo.fr</a>> wrote:<br type="attribution"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
On Friday 14 October 2011 08:17:12 e-mail robert.m.davies wrote:<br>
> I am unable to install digikam since I tried to compile from source.<br>
> I will list the steps I took below.<br>
> If anyone can help me to get digikam back up and running, I'd be very<br>
> appreciative.<br>
><br>
> I had digikam2 installed and working from the PPA under 11.04<br>
> I reported a bug, and was offered help if I could run from the latest git<br>
> version.<br>
> So I uninstalled the digikam2 package and I cloned the digikam2 source onto<br>
> my home partition using git.<br>
> I tried to compile, but I didn't have all the correct dependencies.<br>
> I started installing dependencies 1 by 1 using the method on this page:<br>
> <a href="http://ubuntuforums.org/showthread.php?t=718183" target="_blank">http://ubuntuforums.org/showthread.php?t=718183</a><br>
> After about 6 dependencies, I decided there had to be a better way.<br>
> I found this page: <a href="http://www.digikam.org/drupal/download/dependencies" target="_blank">http://www.digikam.org/drupal/download/dependencies</a><br>
> I tried running 'sudo apt-get build-dep digikam2', but it failed with<br>
> errors. I guess (and only guess) that it was because of the packages I had<br>
> installed manually.<br>
> I don't know how to resolve dependency conflicts. I don't know how to force<br>
> a package to install.<br>
> I gave up trying to install from source and decided to install from the<br>
> repository again, but now this fails with dependency errors too.<br>
> I left it for a while and tried to muddle through using gwenview.<br>
> Today I upgraded to 11.10.<br>
> Digikam still won't install.<br>
> When I try to install 'digikam' from the repository, I get the following<br>
> error:<br>
><br>
> †Package:<br>
> /var/cache/apt/archives/libkface-data_1.0~digikam2.1.1-0ubuntu1_all.deb<br>
><br>
> Error: trying to overwrite<br>
> '/usr/share/kde4/apps/libkface/haarcascades/haarcascade_mcs_righteye.xml',<br>
> which is also in package libkface-1 2.0.0-natty~ppa7kde47<br>
><br>
> Package:<br>
> /var/cache/apt/archives/libkface1_1.0~digikam2.1.1-0ubuntu1_amd64.deb<br>
><br>
> Error: trying to overwrite '/usr/lib/libkface.so.1.0.0', which is also in<br>
> package libkface-1 2.0.0-natty~ppa7kde47<br>
><br>
> From the look of it, it might be worth mentioning that I was subscribed to<br>
> the kubuntu backports ppa, and updated to latest kde before the distro<br>
> upgrade to 11.10<br>
><br>
> Based on this, is anyone able to help me? I miss digikam!<br>
><br>
> Rob<br>
<br>
Try removing all versions of klibface, and re-install after that:<br>
the errors you get indicate that you try to install libkface, while there is<br>
another version installed. And for some reason the installer can't replace the<br>
existing version. This might fail with errors due to other dependencies, so be<br>
careful.<br>
<br>
You could also try to upgrade digikam to version 2.1 (yes, I know there's no<br>
digikam installed actually :) )<br>
<br>
Remco<br>
_______________________________________________<br>
Digikam-users mailing list<br>
<a href="mailto:Digikam-users@kde.org">Digikam-users@kde.org</a><br>
<a href="https://mail.kde.org/mailman/listinfo/digikam-users" target="_blank">https://mail.kde.org/mailman/listinfo/digikam-users</a><br>
</blockquote></div>