[digiKam-users] Multiple Libraries on Mac >> Fail

Peter Orth planetorth at gmail.com
Fri Feb 3 04:55:10 GMT 2023


First, let me express my gratitude for all the time and energy this community expends on the Digikam project. I tried many candidates to replace my beloved iView/Expressions/MediaPro, Digikam is it.

I would very much like to implement multiple libraries on Digikam, as I have different sets of photography with completely different workflows, keyword sets, etc;
a large archive of  work-related jpgs,  thousands of Family pics, Fine Art pics and camera scans of archival negs.
Currently I’m using Digikam for a work-photo DAM and loving it. 

I read through the instructions at https://unix.cafe/wp/en/2020/08/how-to-use-multiple-photo-libraries-with-digikam/, and decided to try creating multiple libraries.

I’m on a Mac M1 OS 13.1. I have worked in Terminal before, but only by dumbly and exactly following instructions. My computer skills are strictly user-oriented. Me on Terminal is like a chimp driving a bus.
Nevertheless, I made a temporary user and went through the process to see if I could get it to work.
The instructions are clear, but I got stuck:

>>Step 5, in order to clone the repository I had to DL Xcode first. All 23 GB worth. There may be a better way, but this made the clone command work
Then I got lost trying to find the script that I had just cloned locally in order to modify it as instructed, and finally gave up.
Unlike many of you, I don’t have the skills to understand exactly what I’m doing in this context, so when something is amiss, I get lost easily.

All this to say that I consider myself a little bit competent (or at least brave) when it comes to this stuff, and despite staying rational, and carefully folIowing instructions, I was unsuccessful.

Could this multi-library functionality be incorporated in a future release? Please?
Could a more idiot-friendly process be mapped out for the likes of me? 
What is the solution to my dead end?

Thanks for your consideration!

Peter Orth

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20230202/d7decb63/attachment.htm>

More information about the Digikam-users mailing list