[digiKam-users] --> Read XMP from Photos.app

Alex Antão alex at familiaturista.com.br
Thu Oct 17 17:46:59 BST 2019

I tried it and didn't work, but I just found out that the problem was that the extension XMP generated by Photos is uppercase, while Digikam expects lowercase. It worked after I renamed the extension. It got all values, but the Date/Time of the file is not stored in that file. Will have to do that manually...


---- Ativado Qui, 17 out 2019 11:43:32 -0300 Gilles Caulier <caulier.gilles at gmail.com> escreveu ----


 the problem is simple : by default digiKam search sidecar file like foo.jpg.xmp for a foo.jpg file. Apple Photo generate foo.xmp instead.

Solution : rename xmp files as well, restart digiKam, select items from icon-view, and run Item/Read metadata from files from main menu


Gilles Caulier

Le jeu. 17 oct. 2019 à 08:04, Alex Antão <mailto:alex at familiaturista.com.br> a écrit :

Hi all,

     Does anybody here knows a way tp transform XMP files from Mac Photos.app to XMP Digikam recognizes ?

     I though this file was standard, but found out that each program has it's own. SO, I have some videos exported from photos, but they have no information. Photos.app exported it's XMP file, but digikam does not import anything frim it. Comparing 2 XMP files (one exported from photos.app and the other generated by digikam) they are totally different (attached). 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20191017/434ee869/attachment.html>

More information about the Digikam-users mailing list