[digiKam-users] matter in switching printer and print from AppImage

Nicolas Boulesteix nico.boulesteix at gmail.com
Fri May 3 17:16:33 BST 2019

Thanks for your answer.

So, is there a way to avoid getting pdf printer as digikam default printer
each time I open "print image" and have my system default printer instead ?
Previously (before dk 5.9 with not appimage version) I have some matter to
set correctly my printer if not the default one, but setting this printer
to default permit to print. Here no.

Is there some debug operation I could post here to help seeing what's wrong
perhaps in my system ?

Any package I could install or check that could missing...

Thanks in advance


Le jeu. 2 mai 2019 à 07:14, Gilles Caulier <caulier.gilles at gmail.com> a
écrit :

> Hi,
> I just checked the AppImage build log, and especially the Qt 5.11.3
> configuration before compiling, and CUPS support is well enabled. So
> printing support is compiled in ApppImage. A printing system is
> located in Qt.
> The difference with the digiKam AppImage < 6.1.0 is the Qt version.
> preview digiKam version used Qt 5.9.7. So switching to 5.11.3 is a big
> step and it's not the last one (5.12.2)
> Best
> Gilles Caulier
> Le lun. 29 avr. 2019 à 15:47, Nicolas Boulesteix
> <nico.boulesteix at gmail.com> a écrit :
> >
> > Hi,
> >
> > I recently try to print some picture on my Epson Wifi connected R3000
> from the Digikam 6.1 appimage on Ubuntu 18.04 64bits, but unsuccessfully.
> >
> > In the past, with earlier repository, ppa or builded version of Digikam,
> I could print, even if, I remember the printer should be set as default
> because having to switch giving some issues, but now, when I try to print
> something, nothing happens.
> >
> > I guess there's may be a matter for the switching of printer to be take
> into account, as initially, the selected printer is always the "print to
> PDF" one (I print from the editor), and when I switch to my printer, the
> properties still doesn't offer advanced options (quality, color, paper
> type, ink parameter...)  and when I try to launch the print, no print job
> appears in the job list for the printer (no tray icon), and obviously, no
> print appears out of the printer.
> >
> > Printing from Darktable works, so, it's not from the printer itself.
> >
> > I tried to install kde systemsettings and printer configuration package,
> but setting Epson R3000 as default printer doesn't change things... So I
> would like to know if this behavior was normal (linked to appimage
> limitation ? but R3000 is listed in avaible printers in Digikam) and if
> there's a possible solution, appart building and installing Digikam myself
> on my OS which don't have up to date digikam package in repository.
> >
> > Thanks in advance
> >
> > Nicolas
> >
> > --
> > Nicolas Boulesteix - Chasseur de Lueurs - http://www.photonoxx.fr

Nicolas Boulesteix - Chasseur de Lueurs - http://www.photonoxx.fr
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20190503/5d17599c/attachment.html>

More information about the Digikam-users mailing list