[digiKam-users] [digiKam] Facebook integration with 5.9 (beta), Fuse issue

Andrey Goreev aegoreev at gmail.com
Wed Feb 21 21:05:54 GMT 2018

 If you get this error:

# fuse: failed to exec fusermount: Permission denied

check permissions of /usr/bin/fusermount:

# ls -lah /usr/bin/fusermount

If the output looks like this:

# -rwsr-x--- 1 root root 31K Jul 17 05:18 /usr/bin/fusermount

then run this command:

# sudo chmod +x /usr/bin/fusermount

to make permissions loke like this:

# ls -lah /usr/bin/fusermount
# -rwsr-x--x 1 root root 31K Jul 17 05:18 /usr/bin/fusermount

Best regards,

On Wed, Feb 21, 2018 at 2:01 PM, Tac Tacelosky <tacman at gmail.com> wrote:

> Thanks -- will 5.9 release require fuse?  If so, can you add more
> instructions, I've followed what I can, but am still stuck.  The other
> missing dependency (in 5.8) was actually pretty easy to install.
> On Wed, Feb 21, 2018 at 2:42 PM, Gilles Caulier <caulier.gilles at gmail.com>
> wrote:
>> 2018-02-21 14:46 GMT+01:00 Tac Tacelosky <tacman at gmail.com>:
>>> I'm wondering if Facebook integration works better in 5.9 (beta), under
>>> Ubuntu 17.10
>>> I tried to see for myself, but can't run the appimage because of a fuse
>>> error.
>>> dlopen(): error loading libfuse.so.2
>>> AppImages require FUSE to run.
>>> You might still be able to extract the contents of this AppImage
>>> if you run it with the --appimage-extract option.
>>> See https://github.com/AppImage/AppImageKit/wiki/FUSE
>>> I've tried to install Fuse following the instructions, and also the with
>>> --appimage-extract option, but no luck.
>> The fuse component is used internally by AppImage to decompress and mount
>> quickly in user sapce the virtual disk from the bundle.
>> If i'm not too wrong, fuse right is managed by user properties. Your
>> account must be listed in fuse group from the system. This is how i use
>> Kate AppImage 32 bits compiled by myself to use on embeded Linux CentOS 6
>> in my office. Typically, the account is just add to fuse group in
>> /etc/groups. You must to be un-logged to see the changes take effect.
>>> Any suggestions?  I've been contributing a bit to the flickr uploader (
>>> https://github.com/TheFox/flickr-cli) with the idea of eventually being
>>> able to use that script to upload to flickr via a queue, but would really
>>> like to simply be able to upload selected images via the integrated DigiKam
>>> tools.
>> The Facebook tool must be ported to OAuth2 to automatize the
>> identification. We will have a student working on this project while this
>> summer. He will also ports others webservice tools to OAuth2, as Google for
>> ex.
>> A lots of changes are planed about webservice tools for next 6.0.0. This
>> is a main goal from my pending tasks since a while : more Qt5 only
>> implementations, available everywhere (editor, light table, showfoto), no
>> run-time loading at startup, and a factored API in digiKam core.
>> I will explain more details later in this room, after to publish the last
>> 5.9.0 release planed in few weeks.
>> Best
>> Gilles Caulier
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20180221/1a5d3389/attachment.html>

More information about the Digikam-users mailing list