broken xmp files

Andrey Goreev aegoreev at
Sun Oct 22 02:41:44 BST 2017

I think Maik might already fixed this. I do recall having a similar conversation a couple of months ago.Have you tried pre-release bundle ver. 5.8.0 ?

Sent from my Samsung Galaxy smartphone.
-------- Original message --------From: Dan McDaniel <dan at> Date: 2017-10-21  7:34 PM  (GMT-07:00) To: digikam-users at Subject: broken xmp files 

I'm using 5.7.0 on a Mac.

I used Digikam to tag and rate about 1000 images, a combination of jpegs
and raws. For about half of them Digikam didn't write a complete xmp
file, but only the first line:

  <?xpacket begin="" id="W5M0MpCehiHzreSzNTczkc9d"?>

On some of them I tried going back into DK and changing the star rating.
This caused it to write out the xmp file including the rating. But it
didn't write the tags. To get DK to write the tags I had to make a
change to a tag. Then to get it to write the title you have to make a
change to the title and so on. Basically, you have to remove stars,
tags, titles, and everything and add them back in to force DK to write
them out to the xmp file.

I hope that this can be fixed because as-is DK isn't very useful to me.

Dan McDaniel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Digikam-users mailing list