[solved] Re: digikam 5.6 mariadb problem

Simon Frei freisim93 at gmail.com
Mon Aug 14 14:49:45 BST 2017

On 14/08/17 15:36, maderios wrote:
> On 08/14/2017 02:45 PM, Simon Frei wrote:
>> The problem is probably with the configuraiton of the mysql server:
>> If the option "bind-address" is set to anything else than
>> localhost/ or (any address) then you can only connact
>> with that specific address. If you didn't modify this yourself, maybe
>> you a mysql/mariadb update changed the default. Or I am wrong and this
>> isn't the problem after all :)
> I found in /etc/mysql/mariadb.conf.d/50-server.cnf
> bind-address =
> I changed dk settings hostname 'localhost' --> ''
> I can connect now :)
> Thanks Gilles & Simon
Glad the problem is solved.

I was puzzled that it makes a difference whether you use 'localhost' or
'', I always assumed the former is just an alias for the
latter. A bit more googling brought up the following SO Q&A:
The problem is that if you use 'localhost', mysql tries to connect via a
unix domain socket and ignores the port (which in your case was the
non-standard 3306). With '' it connects via tcp/ip and uses the
given port.

More information about the Digikam-users mailing list