[Digikam-users] dependency conflict between libopencv and libjpeg9/62-turbo

Andrew Goodbody ajg02 at elfringham.co.uk
Mon Nov 30 23:27:47 GMT 2015

Sorry, yes, oops, reading too fast.

I think it may have something to do with the first three lines of your 
output. They suggest that the system does not know to use QT4 or QT5. 

qtpaths is symlinked to qtchooser on my system


On 30/11/15 22:55, Simon Frei wrote:
> That did not help and I do have libkipi, the output does show that
> libkipi has been found in the build process. I am confused...
> On 30/11/15 20:18, Andrew Goodbody wrote:
>> export GITSLAVE=.gitslave.devel
>> ./download-repos
>> You are missing libkipi...
>> Andrew
>> On 30/11/15 10:42, Simon Frei wrote:
>>> I changed the line suggested by Gilles, but it did not change anything,
>>> as JPEG8_FOUND is false and thus line 87 is never reached due to the
>>> conditional statement.
>>>  From Andrew's statements I think the problem is not even the
>>> libjpeg/rawengine, this is simply the last message printed before
>>> building aborts, the actual problem is somewhere else...
>>> But I do not get what is the problem, the only missing libraries are
>>> optional and the output states that digikam can be compiled. I attached
>>> the output, maybe for you it is obvious.
>>> On 30/11/15 10:33, Gilles Caulier wrote:
>>>> These are new RAWSpeed Codec taken from RawSpeed Codec. These codec
>>>> can process faster Raw file loading and raw demosaicing. That all.
>>>> Same Raw file types are supported in with or without this features.
>>>> Idem for demosaicing methods.
>>>> Gilles Caulier
>>>> 2015-11-30 10:25 GMT+01:00 Andrew Goodbody <ajg02 at elfringham.co.uk
>>>> <mailto:ajg02 at elfringham.co.uk>>:
>>>>     I have not tried raw decoding but dk5 compiles with libjpeg62, it
>>>>     is just that RawEngine disables the RawSpeed codec. I don't know
>>>>     what you lose in that case ie I don't know what that codec would
>>>>     do for you.
>>>>     Andrew
>>>>     On 30 November 2015 08:31:53 GMT+00:00, Gilles Caulier
>>>> <<mailto:caulier.gilles at gmail.com>caulier.gilles at gmail.com> wrote:
>>>>         I don't understand. It work or not ?
>>>>         Gilles Caulier
>>>>         2015-11-30 9:26 GMT+01:00 Andrew Goodbody
>>>> <<mailto:ajg02 at elfringham.co.uk>ajg02 at elfringham.co.uk>:
>>>>             Ahh, OK, I just checked. I just live with RawEngine not
>>>>             supporting the RawSpeed codec.
>>>>             Andrew
>>>>             On 29/11/15 23:33, Simon Frei wrote:
>>>>                 This option is already off, as I have opencv2
>>>>                 installed (off is actually
>>>>                 standard, I did not even have to change that). The
>>>>                 libjpeg error occurs
>>>>                 as part of RawEngine dependencies checks.
>>>>                 On 29/11/15 23:44, Andrew Goodbody wrote:
>>>>                     Hmm, I can't remember the details for sure but I
>>>>                     disabled whatever it
>>>>                     is that needs the libjpeg >=8.
>>>>                     It maybe as simple as editing bootstrap.linux and
>>>>                     changing the
>>>>                     -DENABLE_OPENCV3 from ON to OFF.
>>>>                     Andrew
>>>>                     On 29/11/15 12:15, Simon Frei wrote:
>>>>                         Hi
>>>>                         I am trying to build digikam on debian. I run
>>>>                         into the problem, that I
>>>>                         can install the libopencv and libjpeg9
>>>>                         packages at the same time, but
>>>>                         not their -dev packages, which are needed at
>>>>                         build time. libopencv
>>>>                         depends on libjpeg62-turbo-dev which conflicts
>>>>                         with libjpeg9-dev. So
>>>>                         when building, I am either missing opencv or
>>>>                         the libjpeg version is too
>>>>                         low (>=8 needed).
>>>>                         Can I somehow avoid this problem when building
>>>>                         digikam? And maybe
>>>>                         somebody has some insight in libopencv: Is
>>>>                         there really a problem with
>>>>                         libjpeg versions or is this conflict probably
>>>>                         a bug in the libopencv
>>>>                         package, i.e. would it be reasonable to file a
>>>>                         bug report?
>>>>                         Thanks in advance for any help.
>>>>                         Cheers,
>>>>                         Simon

More information about the Digikam-users mailing list