[Digikam-users] Digikam freezing

David King linuxman at avoura.com
Fri Jun 20 14:07:18 BST 2014

I ran the gdb digikam, etc.

I got the following error repeated over and over again:

digikam(16883)/digikam (core) 
Digikam::DatabaseCoreBackend::prepareQuery: Prepare failed!

I then pressed CTRL C to stop it and got the following as well:

digikam(16883)/digikam (core) 
Digikam::DatabaseCoreBackendPrivate::checkRetrySQLiteLockError: Database 
is locked. Waited 4500

The output from bt is:

#0  0x00007ffff10c7fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fffea00cfe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fffea00d0ec in g_main_context_iteration ()
    from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffff1fe57a1 in 
() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007ffff2a4cbb6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#5  0x00007ffff1fb70af in 
QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from 
#6  0x00007ffff1fb73a5 in 
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from 
#7  0x00000000005df729 in ?? ()
#8  0x00000000005df7d7 in ?? ()
#9  0x00000000005a41b6 in ?? ()
#10 0x00000000004945ca in ?? ()
#11 0x00007ffff0ffbec5 in __libc_start_main (main=0x4936a0, argc=1,
     argv=0x7fffffffe098, init=<optimised out>, fini=<optimised out>,
     rtld_fini=<optimised out>, stack_end=0x7fffffffe088) at 
#12 0x0000000000496f1f in _start ()

The Digikam splash screen opened, the main window opened and a dialog 
box that says it was scanning my collection but got no further than 0% 
and then it disappeared. The main window is currently not displaying 
anything other than a large grey area on the left and white area on the 
right plus the title bar (no menus, folders, etc.)

I am guessing it is something to do with the "Database is locked" error.

David K

On 20/06/14 13:22, Gilles Caulier wrote:
> run kdebugdialog, tuen on debug space and run digiKam from a console
> to look trace.
> It's explained here :
> http://www.digikam.org/contrib
> Gilles Caulier
> 2014-06-20 14:13 GMT+02:00 David King <linuxman at avoura.com>:
>> I am using Ubuntu Studio 14.04, and when using Digikam it keeps freezing at
>> startup. The progress bar at the bottom of the window gets so far and then
>> stops, and nothing responds in the program. I was using version 3.5 and in
>> that it got as far as 91% and then froze.
>> So I uninstalled 3.5 and then downloaded and installed 4.0.0 and its
>> dependencies. Now when I start the program it gets as far as 38%, or
>> sometimes to 91%, and then freezes.
>> I have a lot of photos, and it all worked perfectly okay a few days ago the
>> last time I used it, this has not happened before, nor has anything else
>> changed in regards to the photos themselves. I have kept my Ubuntu Studio up
>> to date with automatic updates.
>> Any ideas why Digikam is freezing and how to get it working again?
>> I note that the digikam site says to have exiv2 at 0.11 or later, mine is
>> 0.23.
>> David K
>> _______________________________________________
>> Digikam-users mailing list
>> Digikam-users at kde.org
>> https://mail.kde.org/mailman/listinfo/digikam-users
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users

More information about the Digikam-users mailing list