[Digikam-users] problems on Fedora 20

George Avrunin avrunin at comcast.net
Sun Aug 17 18:31:18 BST 2014

On Fedora 20, following the update from digikam 3.5 to 4.0 (which I got on
July 26), I'm having some issues with importing images from a Canon EOS

- The camera window doesn't show thumbnails or previews, just icons for
  RAW and/or JPEG.  I can't seem to preview the images to select the ones
  to import.

- Digikam gets the date from JPEGs to do renaming as I have specified, but
  it seems to think that all of the RAW files were created on 1969-12-31
  at 19:00:00, at least from the filenames it's generating.  Once the files
  are imported, the "File properties" shows the correct date. (Well, up to
  time zone issues: my camera is set to Eastern Daylight Time, and Digikam
  seems to be interpreting that as Universal Time and then correcting for
  my computer's time zone, so things are off by 4 hours--but this was true
  before the update, too. Is this a configuration problem on my part?)

- I have digikam set to create a new sub-album with the date; so I have
  <root album>/<year>/<month>/<date>.  I'm importing into the <month>.
  JPEGs are correctly put in a sub-album with the date, but RAW images are
  put into the <month>, not into a sub-album.  I assume this is connected
  to not being able to correctly get the date during the import.

All of this (except for the time zone stuff) worked fine with 3.5.  I
tried downloading the Fedora bodhi builds of digikam 4.2 (which aren't in
the testing repository yet), but I'm seeing the same issues as with 4.0.  I
looked through the mailing list archives and saw that some other people had
problems with previewing images from the camera with Canon cameras on
4.0.  Shotwell seems to be able to generate thumbnails of images in the
camera before downloading and gets the correct dates on RAW images.  

I only started using digikam in early July, so it may well be that this is
pilot error, but I haven't been able to figure it out from the
documentation.  I don't think I changed any digikam settings with the
upgrade from 3.5 to 4.0, and nothing about the camera changed at that

Thanks for any help,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 173 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20140817/052d5914/attachment.sig>

More information about the Digikam-users mailing list