[Digikam-users] Digikam on Mint 17 after update

Philip Johnsson philip.johnsson at gmail.com
Sat Aug 16 12:57:51 BST 2014


My digikam packages in my "extra" PPA is built against KDE 4.13.x that
comes with (k)ubuntu. To work with any 3rd party source with upcoming 4.14
that is in RC state then the packages need to be rebuilt against them to
work but will in that case not work with the standard kde that comes with
(k)ubuntu 14.04 instead. Need two different PPAs with build against the
different KDE versions if that should work.

Regards,

Philip


On Sat, Aug 16, 2014 at 11:32 AM, Mark Fraser <mfraz74+kde at gmail.com> wrote:

> On Thursday 14 Aug 2014 18:12:10 Philip Johnsson wrote:
> > On Thu, Aug 14, 2014 at 8:35 AM, m5ernel <m5ernel at gmail.com> wrote:
> > > Hello.
> > > I've been using Mint for quite a long time. Now 17 Cinnamon is running
> on
> > > my
> > > AMD 64 desktop. had a Digikam 4.2 working quite well until a couple of
> > > days
> > > ago. That day I updated the system with Update manager. And after that
> -
> > > no
> > > more Digikam!
> > > I tried to re-install with apt-get commands (yes, I did apt-get update
> > > first) and what I'd got was:
> > >
> > > /Reading package lists... Done
> > > Building dependency tree
> > > Reading state information... Done
> > > Some packages could not be installed. This may mean that you have
> > > requested an impossible situation or if you are using the unstable
> > > distribution that some required packages have not yet been created
> > > or been moved out of Incoming.
> > > The following information may help to resolve the situation:
> > >
> > > The following packages have unmet dependencies:
> > > digikam : Depends: libkgeomap1 (>= 1.0~digikam4.2.0) but it is not
> going
> > > to
> > > be installed
> > > E: Unable to correct problems, you have held broken packages.
> > > /
> > >
> > > I am just a simple desktop user, no Linux expert. I assume it must be
> some
> > > sort of problem with libkgeomap (version or what?) but have no clue of
> how
> > > to fix it.
> > > Please, help me with some for-dummies-cookbook-like instruction.
> > >
> > > Thanks, regards,
> > > MiloŇ°
>
> > Hi
> >
> > Try to install/upgrade just libkgeomap1 and you will get more information
> > on what causes the conflict not installing/upgrading libkgeomap1. My
> guess
> > is conflicting versions of kde and/or plasma packages and what digikam
> and
> > maybe other kde programs are built to use.
> >
> > Start from there and see what information you get.
> >
> > Regards,
> >
> > Philip
>
> Hi Philip,
> I'm using your PPA with Kubuntu 14.04 and I'm also having trouble with an
> upgrade to KDE 4.13.97 wanting to remove digikam.
>
> Attempting the upgrade with aptitude full-upgrade gives this:
> The following packages have unmet dependencies:
>  libnepomukquery4a : Depends: libkdecore5 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
>  libmarblewidget18 : Depends: libastro1 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
>  libnepomukutils4 : Depends: libkdecore5 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
>                     Depends: libkdeui5 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
>  libnepomuk4 : Depends: libkdecore5 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
>                Depends: libkdeui5 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed.
> The following actions will resolve these dependencies:
>
>      Remove the following packages:
> 1)     digikam
> 2)     kipi-plugins
> 3)     libkgeomap1
> 4)     libmarblewidget18
> 5)     libnepomuk4
> 6)     libnepomukquery4a
> 7)     libnepomukutils4
>
> --
> Registered Linux User #466407 http://counter.li.org
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20140816/85569f92/attachment.html>


More information about the Digikam-users mailing list