[Digikam-users] Cannot access my collection anymore

Nicolas MF nicolasmf at gmail.com
Mon Oct 28 13:03:14 GMT 2013

Hi, I'm in a bit of a situation and hope I have not my db for good (lots of
face tags, geotags, ratings...). I understand this is the appropriate
channel to seek help on digikam, so here goes.

*Sum-up*: I only get to see a folder that says "My albums", with nothing in
it. using digikam 2.5 in ubuntu precise (12.04) from the official repos.

*How I got there*: I tried to compile 3.5 following these instructions:
Although everything seemed fine (no dependencies missing before compiling),
after installing and opening 3.5 all my albums were missing (in digikam,
that is).
I then uninstalled, replaced the db with my backup, and tried 3.3 from the
kubuntu-backports ppa (which I had to add before compiling anyway). Same
thing. So I uninstalled again, switched off the ppa and installed again 2.5
from the official repos but... same thing again. No albums. The db is being
correctly loaded, face tags are there, but no albums or pictures are shown.

So it seems I broke something quite badly. I understand this is no bug (as
they say, in this case the problem is in front of the computer...) but I'd
still need to fix it somehow. Now, before I go about reinstalling ubuntu
altogether, I'd like to know if some configuration data (.digikam or
something similar) are somehow broken or corrupted in my home folder, so
that a clean install wouldn't help. In any case, I'd rather narrow down the
problem before setting out to reinstall everything.
I installed ubuntu 13.10 in a virtual machine to check if 3.4 from an
official repo would have the same problem, but I cannot use the db of my
main install because, I would think, the paths are different.

*So the questions are:*
- has anyone had a similar problem (collection not showing up?) If yes, is
there a fix?
- is there some way for an average user to check if the db is still ok? The
backup should be, but I'd rather make sure.
- How can I perform a test install from a VM, if at all? It would have been
a nice thing to do *before* I broke things up, but I can't see how.
- should I delete anything in my home folder to "reset" digikam's

Any help would be deeply appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20131028/a3bad548/attachment.html>

More information about the Digikam-users mailing list